Blue Mind Forum

Forum about Blue Mind Software

You are not logged in.

Announcement

Bonjour, avant de poster, merci de vérifier que vous avez respecté les pré-requis de l'installation et consultez notre documentation : https://forge.bluemind.net/confluence/display/BM35/ !
Vous pouvez en particulier trouver des réponses aux problèmes les plus courants dans notre FAQ ou encore la base de connaissance.

Hi, before posting on the forum, please check that you followed installation prerequisites and get a look to our documentation space : https://forge.bluemind.net/confluence/display/BM35/ !

#1 Re: Discussions » **Erreur**Installation bm-edge-role » 2020-05-04 11:23:24

Bonjour Toony, merci pour les infos.
Je penses que mon souci était situé là, car j'avais complétement remplacé les fichiers main.cf et master.cf plutot que d'ajouter les parametres dans le fichier existant généré par Bluemind.

#2 Re: Discussions » **Erreur**Installation bm-edge-role » 2020-04-30 14:16:43

Bonjour Toony, j'ai contourné mon problème en installant un Proxmox Mail Gateway.
Autrement oui j'avais bien assigné le serveur edge au domaine et il était bien remonté dans l'interface seulement quand je faisais cela la configuration de postfix sur le edge était complétement effacée et remplacée par une autre ( je suppose que cela est un fonctionnement normal smile ).
Donc je remettais ma configuration d'origine et cela faisait planter le serveur principal.
Les modifications était sur les fichiers main.cf et master.cf ainsi que sur les fichiers transport et alias..
Les modifications du main.cf concernait le port d'ecoute pour amavis 10024 ainsi que d'autres parametres au niveau securité ( sasl...)
La bannière affichée aussi.
Je referais un essai en faisant un lab à l'occasion.
Merci à toi smile

#3 Re: Discussions » **Erreur**Installation bm-edge-role » 2020-04-17 23:33:59

Par contre cela m'a virée toute ma conf de postfix au niveau du main.cf et master.cf, je l'avais modifiée pour utiliser amavis et dès que je la remets ça fait planter le serveur principal ??

#4 Re: Discussions » **Erreur**Installation bm-edge-role » 2020-04-17 19:45:45

Nickel, cela fonctionne merci beaucoup pour ton aide M@nu !
Bon weekend

smile

#5 Re: Discussions » **Erreur**Installation bm-edge-role » 2020-04-17 18:05:03

Voici le contenu de /etc/bm
ls -al /etc/bm
total 44
drwxr-xr-x   3 root root      4096 avril 18  2019 .
drwxr-xr-x 110 root root     12288 avril 17 18:16 ..
-r--r-----   1 root www-data    36 avril 18  2019 bm-core.tok
-rw-r--r--   1 root root       207 avril 18  2019 bm.ini
-r--------   1 root root      3407 avril 18  2019 bm.jks
drwxr-xr-x   2 root root      4096 avril 18  2019 default
-rw-r--r--   1 root root        36 avril 18  2019 mcast.id
-r--------   1 root root       932 avril 18  2019 nodeclient_truststore.jks
-rw-r--r--   1 root root        36 avril 18  2019 server.uid
root@srvproxy:/etc/bm# Impossible de le declarer dans BlueMind > Serveurs de l'applications car j'ai l'erreur "Erreur lors de la création du serveur : Unknown ping error "

Je précise que le serveur edge fonctionnait avant que je migre en 4.1, j'étais sur une 4.0 c'est peut etre cela le problème?
Le serveur edge à peut etre garder une config particulière non?

#6 Re: Discussions » **Erreur**Installation bm-edge-role » 2020-04-17 17:09:49

J'ai lancer les commandes sans resultat.
J'ai trouvé cela dans les logs core.log, apparemment une erreur de connexion ssl??

2020-04-16 20:30:25,511 [BM-Core1] n.b.n.c.AHCNodeClientFactory INFO - Error testing SSL connection to 192.168.20.205: java.util.concurrent.ExecutionException: java.net.ConnectException: General SSLEngine problem
2020-04-16 20:30:25,513 [BM-Core1] n.b.n.c.AHCNodeClientFactory INFO - [SSL: false] Client configured for 192.168.20.205, ws: net.bluemind.node.client.impl.WebsocketLink@54a36a3
2020-04-16 20:30:25,514 [New I/O boss #18] n.b.n.c.i.WebsocketLink ERROR - websocket error: Connection refused: /192.168.20.205:8021
2020-04-16 20:30:35,516 [New I/O boss #18] n.b.n.c.i.a.DefaultAsyncHandler WARN - onThrowable: class java.net.ConnectException Connection refused: /192.168.20.205:8021
2020-04-16 20:30:35,518 [BM-Core1] n.b.n.c.i.a.AHCHttpNodeClient ERROR - java.net.ConnectException: Connection refused: /192.168.20.205:8021
java.lang.RuntimeException: java.net.ConnectException: Connection refused: /192.168.20.205:8021
Caused by: java.net.ConnectException: Connection refused: /192.168.20.205:8021
Caused by: java.net.ConnectException: Connection refused: /192.168.20.205:8021
2020-04-16 20:30:35,518 [BM-Core1] n.b.c.r.b.RestServiceMethodHandler ERROR - Error during restcall RestRequest [path=/api/servers/default/65d6ad54-11ef-48d2-b478-b9cbb5652a9e, method=PUT, User-Agent=Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0, params=, remoteAddresses=[192.168.20.253, 192.168.20.205, 127.0.0.1], origin=null]:  class net.bluemind.core.api.fault.ServerFault: Unknown ping error

#7 Re: Discussions » **Erreur**Installation bm-edge-role » 2020-04-17 16:26:10

et la commande service bm-node status

● bm-node.service - BlueMind Node Server.
   Loaded: loaded (/usr/share/bm-node; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2020-04-17 16:43:08 CEST; 41min ago
Main PID: 1267 (java)
   CGroup: /system.slice/bm-node.service
           └─1267 /usr/lib/jvm/bm-jdk/bin/java -Xrs -Dlogback.configurationFile=/usr/share/bm-conf/logs/bm-node.log.xml -Dio.netty.native.workdir=/var/lib/bm-node/work -Xloggc:/var/log/garbage-collector/bm-node/

avril 17 16:43:00 srvproxy systemd[1]: Starting BlueMind Node Server....
avril 17 16:43:01 srvproxy bm-node[1267]: /usr/share/bm-node/equinox-systemd.lib: ligne 24: avertissement :setlocale : LC_ALL : impossible de changer le paramètre de langue (en_US.UTF-8)
avril 17 16:43:08 srvproxy systemd[1]: Started BlueMind Node Server..

#8 Re: Discussions » **Erreur**Installation bm-edge-role » 2020-04-17 16:24:02

Bonjour, voici ce que retourne la commande bmctl all_status
BlueMind bm-locator is down.
BlueMind bm-core is running.
BlueMind bm-elasticsearch is down.
BlueMind bm-tika is running.
BlueMind bm-lmtpd is down.
BlueMind bm-cyrus-imapd is down.
BlueMind bm-webserver is down.
BlueMind bm-php-fpm is down.
BlueMind bm-xmpp is down.
BlueMind bm-milter is running.
BlueMind bm-ysnp is running.
BlueMind bm-eas is down.
BlueMind bm-hps is down

#9 Re: Discussions » **Erreur**Installation bm-edge-role » 2020-04-17 11:50:13

J'ai ce message dans core.log si cela est utile:

2020-04-16 20:40:40,461 [BM-Core20] n.b.c.r.b.RestServiceMethodHandler ERROR - Error during restcall RestRequest [path=/api/servers/default/a8aa7a56-a8fc-44d5-9ac5-7dedbef400ac, method=PUT, User-Agent=Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:75.0) Gecko/20100101 Firefox/75.0, params=, remoteAddresses=[192.168.20.253, 192.168.20.205, 127.0.0.1], origin=null]:  class net.bluemind.core.api.fault.ServerFault: Unknown ping error
        at net.bluemind.node.client.impl.ahc.AHCHttpNodeClient.ping(AHCHttpNodeClient.java:73)
Fichier binaire (entrée standard) correspondant

#10 Discussions » **Erreur**Installation bm-edge-role » 2020-04-17 10:45:12

loloteftef
Replies: 16

Bonjour a tous.
je rencontre un souci pour ajouter un serveur relai dans la console d'administration, j'ai un message d'erreur "Erreur lors de la création du serveur : Unknown ping error ".
Je précise que cela fonctionnait avant sur la version 4.0.1. J'ai migré sur la version 4.1.5 hier sur un nouveau serveur et depuis impiossible de rattacher le serveur edge.
Merci de votre aide
smile

Board footer

Powered by FluxBB