You are not logged in.

Announcement

Bonjour, avant de poster, merci de vérifier que vous avez respecté les pré-requis de l'installation et consultez notre documentation : http://docs.blue-mind.net !

Hi, before posting on the forum, please check that you followed installation prerequisites and get a look to our documentation space : http://docs.blue-mind.net

#1 2019-03-16 13:40:50

dani
Member
From: Bordeaux
Registered: 2018-10-13
Posts: 57
Website

EAS incomplet sur BM4

Bonjour.
Toujours dans mes tests sur BM4. J'ai quelques problèmes avec la synchro ActiveSync avec mon Android. Ce même Android fonctionne bien avec BM3.5 (c'est un Huawei Mate 8, sous Android 7.0)

Je crée mon compte EAS, j'autorise le device sur BM, et là :

  • Pas de soucis visible pour mon agenda (excepté que seul mon agenda est synchro, pas les autres auxquels je suis abonné, malgré la fonction activée avec le fichier /root/eas.multical). Ce point je le met à part, puisque j'ai le même comportement avec BM3.5, donc ça vient peut être de mon tél

  • Pour les contacts, il n'apparaissent pas dans mon carnet local, mais sont trouvés "parfois" en lançant la recherche Exchange en ligne. Je met parfois, parce que j'ai configuré, puis détruit le compte plusieurs fois, de la même façon, et je n'ai pas toujours le même comportement. Là par exemple, les contacts ne sont même plus trouvés avec la recherche en ligne, alors qu'hier ils l'étaient. Sur BM3.5, pas de problème avec ce tél, les contacts se synchronisent bien

  • Dernier problème, et probablement le plus important, la synchro mail est largement incomplète. Mon INBOX apparaît vide, alors que j'ai plusieurs emails dedans. La liste des dossiers de la boîte est aussi incohérente. La plupart des répertoires sont absents, ceux présents n’apparaissent au bon endroit (par exemple, un répertoire "firewall-services" apparaît comme étant à la racine, alors qu'il est dans un sous dossier nommé Arbo). Et ces dossiers qui apparaissent n'affichent pas le contenu des mails qui sont réellement dedans

Bref, l'EAS n'est pas vraiment exploitable là, pour mon compte. À priori, un autre compte sur le même serveur ne rencontre pas de problème. Dans les logs /var/log/bm-eas je ne vois pas d'erreur visible. J'ai essayé de lancer la réindexation, et la réparation du compte, sans changement. J'ai réinitialisé la synchro de l'appareil. J'ai essayé avec un autre client ActiveSync (Bluemail) avec les mêmes résultats.

Comment faire pour débuguer ça ?


Firewall Services: la sécurité des réseaux

Offline

#2 2019-03-17 12:27:46

dani
Member
From: Bordeaux
Registered: 2018-10-13
Posts: 57
Website

Re: EAS incomplet sur BM4

Je me concentre sur la synchro des mails. Il semble en fait que Bluemind ne "voit" pas correctement l'arbo IMAP existante. Même si je lance un check&repair, il essaie de réparer des répertoires qui n'existent pas, et ne scan pas les répertoires qui existent

dani.Matrix@fws.fr : Repairing bodies for mailbox dani.Matrix@fws.fr : NOTHING TO DO
dani.glpi@fws.fr : Repairing bodies for mailbox dani.glpi@fws.fr : NOTHING TO DO
dani.Migration/Drafts/5C8B9403@fws.fr : Repairing bodies for mailbox dani.Migration/Drafts/5C8B9403@fws.fr : NOTHING TO DO
dani.Migration/5C8B9A7F@fws.fr : Repairing bodies for mailbox dani.Migration/5C8B9A7F@fws.fr : NOTHING TO DO
dani.Drafts@fws.fr : Repairing bodies for mailbox dani.Drafts@fws.fr : NOTHING TO DO
dani.Migration/INBOX/5C8B9A7D@fws.fr : Repairing bodies for mailbox dani.Migration/INBOX/5C8B9A7D@fws.fr : NOTHING TO DO
dani.Migration/Archive/5C8B9407@fws.fr : Repairing bodies for mailbox dani.Migration/Archive/5C8B9407@fws.fr : NOTHING TO DO
dani.Outbox@fws.fr : Repairing bodies for mailbox dani.Outbox@fws.fr : NOTHING TO DO
dani.INBOX@fws.fr : Repairing bodies for mailbox dani.INBOX@fws.fr : NOTHING TO DO
dani.Junk@fws.fr : Repairing bodies for mailbox dani.Junk@fws.fr : NOTHING TO DO
dani.Sent@fws.fr : Repairing bodies for mailbox dani.Sent@fws.fr : NOTHING TO DO
dani.Migration/Brouillons/5C8B93FE@fws.fr : Repairing bodies for mailbox dani.Migration/Brouillons/5C8B93FE@fws.fr : NOTHING TO DO
dani.Trash@fws.fr : Repairing bodies for mailbox dani.Trash@fws.fr : NOTHING TO DO
dani.builds@fws.fr : Repairing bodies for mailbox dani.builds@fws.fr : NOTHING TO DO
dani.firewall-services@fws.fr : Repairing bodies for mailbox dani.firewall-services@fws.fr : NOTHING TO DO

J'ai bien eu à un moment un répertoire Migration, mais qui n'existe plus maintenant (réorganisation de mes répertoires avec le webmail, et avec Thunderbird). Les répertoires Matrix, builds, glpi existent, mais ne sont pas à la racine, ils sont sous le répertoire firewall-services. Ce même répertoire firewall-services n'est pas à la racine non plus. Bref, il semble qu'il y a ait un gros décalage entre l'arbo IMAP et Bluemind. Comment faire pour resynchroniser tout ça ? Ce décalage semble être à l'origine des pb de synchro EAS, mais aussi de l'impossibilité de créer des filtres sieve (puisque les répertoires qui existent n'apparaissent pas le menu déroulant "Déplacer vers"


Firewall Services: la sécurité des réseaux

Offline

#3 2019-03-17 18:00:28

dani
Member
From: Bordeaux
Registered: 2018-10-13
Posts: 57
Website

Re: EAS incomplet sur BM4

J'avance petit à petit dans mon analyse sur les problèmes de répertoires IMAP. Dans BM3.5, il semble que ces info étaient stockées dans la table t_folder. Mais cette table n'existe pas sur mon installation de BM4. Je suppose donc qu'il y a un changement de schéma. Où est stocké cette info dans la base de BM4, et comment la reconstruire ?


Firewall Services: la sécurité des réseaux

Offline

#4 2019-03-18 09:08:08

aaujon
Member
Registered: 2016-01-07
Posts: 289

Re: EAS incomplet sur BM4

Bonjour,

Les dossiers IMAP sont stockés dans t_container_hierarchy, de la BD bj-data (toutes les donnés utilisateurs sont stockés dans bj-data en 4.0).
La synchronisation des dossiers se fait maintenant via le processus de replication de cyrus, cela indique probablement que la replication ne fonctionne plus.
Est ce que tu peux ouvrir un ticket sur notre bug tracker ? Nous te demanderons sûrement un accès SSH au serveur afin de diagnostiquer le problème, merci.

Offline

#5 2019-03-18 15:53:03

dani
Member
From: Bordeaux
Registered: 2018-10-13
Posts: 57
Website

Re: EAS incomplet sur BM4

Ticket ouvert / mis à jour : https://forge.bluemind.net/jira/browse/BM-14377


Firewall Services: la sécurité des réseaux

Offline

#6 2019-04-20 11:27:49

SuPeRFlOuP
Member
Registered: 2019-04-18
Posts: 1

Re: EAS incomplet sur BM4

Bonjour à tous,

Je rencontre des soucis similaires à dani avec l'EAS sur Android et Bluemind 4.0.2 (fonctionnalités qui fonctionnent à merveille sur l'ancien serveur en 3.5.12-2), à savoir :
- Le multical ne fonctionne pas avec les agenda partagés. J'ai testé de partager un agenda avec un groupe ou utilisateur ou en créant une ressource et le résultat est le même. Le dysfonctionnement concerne tous les utilisateurs (seulement 4, c'est un serveur familial)
- La synchronisation des emails fonctionne bien mais le push mail ne fonctionne pas du tout, on ne reçoit pas de notifications. Cependant, si on lance une synchro manuelle, on reçoit bien nos emails.

Avez-vous pu avancer sur ses dysfonctionnements s'il vous plaît ? J'aimerais migrer vers mon nouveau serveur mais je vais patienter et continuer à utiliser l'ancien serveur. big_smile

Last edited by SuPeRFlOuP (2019-04-20 11:45:51)

Offline

Board footer

Powered by FluxBB