Blue Mind Forum

Forum about Blue Mind Software

You are not logged in.

Announcement

Bonjour, avant de poster, merci de vérifier que vous avez respecté les pré-requis de l'installation et consultez notre documentation : https://forge.bluemind.net/confluence/display/BM35/ !
Vous pouvez en particulier trouver des réponses aux problèmes les plus courants dans notre FAQ ou encore la base de connaissance.

Hi, before posting on the forum, please check that you followed installation prerequisites and get a look to our documentation space : https://forge.bluemind.net/confluence/display/BM35/ !

#1 2012-05-15 08:32:05

Lusis
Member
Registered: 2012-05-14
Posts: 3

port d'écoute 443

Bonjour,
Suite au reboot du serveur, le port 443 n'écoute plus malgré la présence de tous les composants bm-.
Aucune anomalie non constatée dans les logs. Avez vous une piste ?.

Offline

#2 2012-05-15 09:39:59

Toony
BlueMind Team
From: Toulouse
Registered: 2012-03-29
Posts: 1,867
Website

Re: port d'écoute 443

Quelle distribution utilisez vous ?

À priori, c'est le service nginx qui n'est pas démarré. Que donne la commande :

/etc/init.d/nginx restart

Avez-vous un message dans les logs de nginx (/var/log/nginx) ?

Offline

#3 2012-05-15 15:55:06

Lusis
Member
Registered: 2012-05-14
Posts: 3

Re: port d'écoute 443

D'abord, merci pour votre réactivité...

la distrib utilisée est bm-full-0.15.4729-0.x86_64.
Effectivement c'était bien nginx qui méttait la grouille. En relancant ce service, il y eu le message suivant:
[emerg] unknown directive "/127.0.0.1:8079/settings/" in /etc/nginx/sites-enabled/bm-client-access:76

En supprimant les  3 dernieres lignes ci dessous du fichier /etc/nginx/sites-enabled/bm-client-access ,  c'est bien reparti. Mais quizz de comment elles se sont insérées car à l'installation le port 443 fonctionnait bien

/127.0.0.1:8079/settings/;
  }
}

Offline

#4 2012-05-15 16:28:47

Toony
BlueMind Team
From: Toulouse
Registered: 2012-03-29
Posts: 1,867
Website

Re: port d'écoute 443

Je parlais de distribution Linux que vous utilisez (Ubuntu 10.04, CentOS 6... smile)

Vous avez simplement supprimé les 3 lignes indiquées dans votre précédent post, et qui se trouvaient à la fin du fichier /etc/nginx/sites-enabled/bm-client-access ?
Pouvez-vous nous faire passer votre fichier /etc/nginx/sites-enabled/bm-client-access actuel ?

Il nous faudrait aussi le résultat des commandes :

# hostname

et

# hostname -f

Offline

#5 2012-05-24 10:21:23

Lusis
Member
Registered: 2012-05-14
Posts: 3

Re: port d'écoute 443

Nous sommes en Centos  6.2  64 bits.

Oui, simplement en supprimant ces 3 lignes .
Voici le fichier demandé:
# Blue Mind client access proxy
server {
  listen   80;
  server_name  webmail.lusis.fr;

  location / {
    rewrite ^ https://webmail.lusis.fr$request_uri? redirect;
  }

}


server {
  listen   443;
  server_name  webmail.lusis.fr;

  ssl  on;
  ssl_certificate  /etc/ssl/certs/bm_cert.pem;
  ssl_certificate_key  /etc/ssl/certs/bm_cert.pem;
 
  ssl_session_timeout  5m;
  ssl_protocols  SSLv3 TLSv1;
  ssl_ciphers  ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv3:+EXP;
  ssl_prefer_server_ciphers   on;

  location / {
    proxy_pass http://127.0.0.1:8079/;
  }

  location /templates/ {
    proxy_pass http://127.0.0.1:8079/templates/;
  }

  location /webmail/ {
    client_max_body_size 10m;
    proxy_pass http://127.0.0.1:8079/webmail/;
  }

  location /adminconsole/ {
    proxy_pass http://127.0.0.1:8079/adminconsole/;
    client_max_body_size 10m;
  }

  location /setup/ {
    auth_basic            "Blue Mind Setup";
    auth_basic_user_file  /etc/nginx/sw.htpasswd;
    proxy_pass http://127.0.0.1:8080/setup/;
  }

  location /services {
    proxy_pass http://127.0.0.1:8085/services;
    client_max_body_size 10m;
  }

  location /freebusy {
    proxy_pass http://127.0.0.1:8085/freebusy;
  }

  location /Microsoft-Server-ActiveSync {
    proxy_pass http://127.0.0.1:8082/Microsoft-Server-ActiveSync;
    proxy_read_timeout 1200s;
  }

  location /cal/ {
    proxy_pass http://127.0.0.1:8079/cal/;
  }

  location /contact/ {
    proxy_pass http://127.0.0.1:8079/contact/;
  }

  location /settings/ {
    proxy_pass http://127.0.0.1:8079/settings/;
  }
}


[root@muriel ~]# hostname
muriel
[root@muriel ~]# hostname -f
muriel.lusis

Offline

Board footer

Powered by FluxBB